Commit 7516ac23 authored by Marcel Huber's avatar Marcel Huber
Browse files

fix parse_requirements for newer pip versions

parent 9297b09f
Pipeline #5572 passed with stages
in 3 minutes and 36 seconds
......@@ -12,6 +12,7 @@ build:
- docker
script:
- tox2 --version
- pip2 --version
- tox2 --recreate -e wheel
test:
......
......@@ -18,7 +18,10 @@ Setup script to generate a python module from the sources.
import os
import codecs
from setuptools import setup
from pip.req import parse_requirements
try: # for pip >= 10
from pip._internal.req import parse_requirements
except ImportError: # for pip <= 9.0.3
from pip.req import parse_requirements
import versioneer
PACKAGE = 'SConsider'
......
......@@ -125,6 +125,6 @@ whitelist_externals =
commands =
- bash -c \
"for n in setup.py $(find SConsider tests '(' -name '*.sconsider' -o -name '*.py' ')'); do \
yapf --in-place $n; \
yapf --in-place $n || echo reformat failed at $n; \
docformatter --in-place $n; \
done"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment